Monkey Studio IDE The way IDEs should be

Compiling Monkey Studio 1.8.3.0

Hi,
I am on Gentoo x86 and when i try to compile Monkey Studio 1.8.3.0, i have an error :

g++ -c -pipe -O2 -march=i686 -pipe -fPIC -D_REENTRANT -Wall -W -DPACKAGE_NAME="\"Monkey Studio\"" -DPACKAGE_VERSION="\"1.8.3.0\"" -DPACKAGE_DOMAIN="\"www.monkeystudio.org\"" -DPACKAGE_COPYRIGHTS="\"Copyright (C) 2005 - 2008 Filipe AZEVEDO\"" -DPACKAGE_PREFIX="\"/usr/local/bin\"" -DPACKAGE_PLUGINS="\"/usr/local/lib/monkeystudio\"" -DPACKAGE_DATAS="\"/usr/local/share/monkeystudio\"" -DSYSTEM_QSCINTILLA -DMONKEY_CORE_BUILD -DQT_NO_DEBUG -DQT_XML_LIB -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtXml -I/usr/include/qt4 -Isdk -I/usr/include -I../build/release/.moc -I/home/palkeo/Desktop/mks_1.8.3.0-svn2673-src/mks_1.8.3.0-svn2673/build/release/.ui -o ../build/release/.obj/unix/pFileDialog.o widgets/pFileDialog.cpp
widgets/pFileDialog.cpp: In member function ‘QFlags pFileDialog::filterForMode() const’:
widgets/pFileDialog.cpp:96: erreur: ‘filter’ was not declared in this scope
widgets/pFileDialog.cpp: In static member function ‘static void pFileDialog::setDialog(pFileDialog*, const QString&, const QString&, const QString&, bool, bool, QString*, QFlags)’:
widgets/pFileDialog.cpp:132: erreur: ‘class pFileDialog’ has no member named ‘setNameFilter’
widgets/pFileDialog.cpp:147: erreur: ‘class pFileDialog’ has no member named ‘selectNameFilter’
[...]
make[1]: *** [../build/release/.obj/unix/pFileDialog.o] Erreur 1
make[1]: quittant le répertoire « /home/palkeo/Desktop/mks_1.8.3.0-svn2673-src/mks_1.8.3.0-svn2673/fresh »
make: *** [sub-fresh-make_default] Erreur 2

Do you know how to solve this problem ?

pasnox's picture

You need Qt version 4.4.0

You need Qt version 4.4.0 minimum for building MkS.
Wich version are you using ?

You can seek team on IRC.
If you don't know what is IRC, then go to the IRC page.
If you want an answer, please be explicit and verbose.
Help by email will be ignored.

Ok : I am using Qt 4.3.3… I

Ok : I am using Qt 4.3.3… I will update my Qt version.
Thanks :)